re = /^.*filename[^;=\n]*=(([\'"]).*?\2|[^;\n]*)[\n;]?$/i
str = 'attachment;filename="AS038100-KT.pdf"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end