#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^.*filename[^;=\n]*=(([\'"]).*?\2|[^;\n]*)[\n;]?$"
Local $sString = "attachment;filename="AS038100-KT.pdf""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")