$re = '/^.*filename[^;=\n]*=(([\'"]).*?\2|[^;\n]*)[\n;]?$/i';
$str = 'attachment;filename="AS038100-KT.pdf"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);