using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*filename[^;=\n]*=(([\'""]).*?\2|[^;\n]*)[\n;]?$";
string input = @"attachment;filename=""AS038100-KT.pdf""";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}