use strict;
my $str = '/^(?=.*\\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\\w\\d\\s:])([^\\s]){8,16}$/gm
_}24I:9t58Tu?m@e
|YlzEc|1
#m_4xF%t"Bu5jeb$
Password1!
12345678aA
^@},^@},^@},
12345678aA@
12345678 aA@
12345678aA@
AbCdEfGhIi
abcdefgh123
ABCDEFGH1234';
my $regex = qr/^(?=.*\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\w\d\s:])([^\s]){8,16}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}