#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\w\d\s:])([^\s]){8,16}$"
Local $sString = "/^(?=.*\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\w\d\s:])([^\s]){8,16}$/gm" & @CRLF & _
"_}24I:9t58Tu?m@e" & @CRLF & _
"|YlzEc|1" & @CRLF & _
"#m_4xF%t"Bu5jeb$" & @CRLF & _
"Password1!" & @CRLF & _
"12345678aA" & @CRLF & _
"^@},^@},^@}," & @CRLF & _
"12345678aA@ " & @CRLF & _
"12345678 aA@" & @CRLF & _
" 12345678aA@" & @CRLF & _
"AbCdEfGhIi" & @CRLF & _
"abcdefgh123" & @CRLF & _
"ABCDEFGH1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")