import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\\w\\d\\s:])([^\\s]){8,16}$";
final String string = "/^(?=.*\\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\\w\\d\\s:])([^\\s]){8,16}$/gm\n"
+ "_}24I:9t58Tu?m@e\n"
+ "|YlzEc|1\n"
+ "#m_4xF%t\"Bu5jeb$\n"
+ "Password1!\n"
+ "12345678aA\n"
+ "^@},^@},^@},\n"
+ "12345678aA@ \n"
+ "12345678 aA@\n"
+ " 12345678aA@\n"
+ "AbCdEfGhIi\n"
+ "abcdefgh123\n"
+ "ABCDEFGH1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}