using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\w\d\s:])([^\s]){8,16}$";
string input = @"/^(?=.*\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\w\d\s:])([^\s]){8,16}$/gm
_}24I:9t58Tu?m@e
|YlzEc|1
#m_4xF%t""Bu5jeb$
Password1!
12345678aA
^@},^@},^@},
12345678aA@
12345678 aA@
12345678aA@
AbCdEfGhIi
abcdefgh123
ABCDEFGH1234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}