$re = '/(private|public) ([A-Za-z_][A-Za-z_0-9.]*) ?\(((.*,)*.*)\) ?\{(.*)\}/m';
$str = 'public aboba(str in, box[int a, int b] c) {return $std:convert.toInt(in) + c;};';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);