using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(private|public) ([A-Za-z_][A-Za-z_0-9.]*) ?\(((.*,)*.*)\) ?\{(.*)\}";
string input = @"public aboba(str in, box[int a, int b] c) {return $std:convert.toInt(in) + c;};";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}