const regex = /(private|public) ([A-Za-z_][A-Za-z_0-9.]*) ?\(((.*,)*.*)\) ?\{(.*)\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(private|public) ([A-Za-z_][A-Za-z_0-9.]*) ?\\(((.*,)*.*)\\) ?\\{(.*)\\}', 'gm')
const str = `public aboba(str in, box[int a, int b] c) {return \$std:convert.toInt(in) + c;};`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}