import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(private|public) ([A-Za-z_][A-Za-z_0-9.]*) ?\\(((.*,)*.*)\\) ?\\{(.*)\\}";
final String string = "public aboba(str in, box[int a, int b] c) {return $std:convert.toInt(in) + c;};";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}