re = /\.(?![a-z0-9]{3,4}$)/m
str = 'names.with.periods.and.extension
names#with$Special&chars*yuhyuh.yuh.yuh..yuhyuh
Normal . Name . with 123 some numbers.mp3
Normal . Name . with 123 some numbers.mpeg
Normal . Name . with 123 ..some . numbers mpeg.123'
subst = '@@@'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result