# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\.(?![a-z0-9]{3,4}$)"
test_str = ("names.with.periods.and.extension\n"
"names#with$Special&chars*yuhyuh.yuh.yuh..yuhyuh\n"
"Normal . Name . with 123 some numbers.mp3\n"
"Normal . Name . with 123 some numbers.mpeg\n"
"Normal . Name . with 123 ..some . numbers mpeg.123")
subst = "@@@"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.