$re = '/\.(?![a-z0-9]{3,4}$)/m';
$str = 'names.with.periods.and.extension
names#with$Special&chars*yuhyuh.yuh.yuh..yuhyuh
Normal . Name . with 123 some numbers.mp3
Normal . Name . with 123 some numbers.mpeg
Normal . Name . with 123 ..some . numbers mpeg.123';
$subst = "@@@";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;