const regex = /\.(?![a-z0-9]{3,4}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?![a-z0-9]{3,4}$)', 'gm')
const str = `names.with.periods.and.extension
names#with\$Special&chars*yuhyuh.yuh.yuh..yuhyuh
Normal . Name . with 123 some numbers.mp3
Normal . Name . with 123 some numbers.mpeg
Normal . Name . with 123 ..some . numbers mpeg.123`;
const subst = `@@@`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);