import Foundation
let pattern = #"Project\("(?<Guid1>\{[\w-]+\})"\)\s*=\s*"(?<ProjectName>[\w\.]+)",\s*"(?<Path>.+)"\s*,\s"(?<Guid2>\{[\w-]+\})""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Logger.Core", "..\..\Logger\Development\Logger.Core\Logger.Core.csproj", "{07095870-CF46-45F4-8E84-8B3C586BBF44}""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)