#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Project\("(?<Guid1>\{[\w-]+\})"\)\s*=\s*"(?<ProjectName>[\w\.]+)",\s*"(?<Path>.+)"\s*,\s"(?<Guid2>\{[\w-]+\})""
Local $sString = "Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Logger.Core", "..\..\Logger\Development\Logger.Core\Logger.Core.csproj", "{07095870-CF46-45F4-8E84-8B3C586BBF44}""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")