using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Project\(""(?<Guid1>\{[\w-]+\})""\)\s*=\s*""(?<ProjectName>[\w\.]+)"",\s*""(?<Path>.+)""\s*,\s""(?<Guid2>\{[\w-]+\})""";
string input = @"Project(""{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}"") = ""Logger.Core"", ""..\..\Logger\Development\Logger.Core\Logger.Core.csproj"", ""{07095870-CF46-45F4-8E84-8B3C586BBF44}""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}