re = /Project\("(?<Guid1>\{[\w-]+\})"\)\s*=\s*"(?<ProjectName>[\w\.]+)",\s*"(?<Path>.+)"\s*,\s"(?<Guid2>\{[\w-]+\})"/
str = 'Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "Logger.Core", "..\\..\\Logger\\Development\\Logger.Core\\Logger.Core.csproj", "{07095870-CF46-45F4-8E84-8B3C586BBF44}"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end