// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.* - Installing)\s([a-zA-Z\/-]*) [(](v[.0-9]*)").unwrap();
let string = " - Installing lubusin/laravel-decomposer (v1.2.2): Downloading (connecting...)Downloading (100%) ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}