package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.* - Installing)\s([a-zA-Z\/-]*) [(](v[.0-9]*)`)
var str = ` - Installing lubusin/laravel-decomposer (v1.2.2): Downloading (connecting...)Downloading (100%) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}