$re = '/^(.* - Installing)\s([a-zA-Z\/-]*) [(](v[.0-9]*)/';
$str = ' - Installing lubusin/laravel-decomposer (v1.2.2): Downloading (connecting...)Downloading (100%) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);