import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.* - Installing)\\s([a-zA-Z\\/-]*) [(](v[.0-9]*)";
final String string = " - Installing lubusin/laravel-decomposer (v1.2.2): Downloading (connecting...)Downloading (100%) ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}