$re = '/^998([378]{2}|(9[013-57-9]))\d{7}$/';
$str = '998912434445';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);