using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^998([378]{2}|(9[013-57-9]))\d{7}$";
string input = @"998912434445";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}