const regex = /^998([378]{2}|(9[013-57-9]))\d{7}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^998([378]{2}|(9[013-57-9]))\\d{7}$', '')
const str = `998912434445`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}