package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^998([378]{2}|(9[013-57-9]))\d{7}$`)
var str = `998912434445`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}