re = /abc\/\K([\w\.]+)(\&\w+)$/m
str = 'http://www.insperity.com/abc/trung.hoang&video
http://www.insperity.com/abc/trung.hoang&video&fsdf
http://www.insperity.com/abc/trung.hoangvideo
http://www.insperity.com/trung.hoang&video
http://www.insperity.com/trung.hoangvideo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end