$re = '/abc\/\K([\w\.]+)(\&\w+)$/m';
$str = 'http://www.insperity.com/abc/trung.hoang&video
http://www.insperity.com/abc/trung.hoang&video&fsdf
http://www.insperity.com/abc/trung.hoangvideo
http://www.insperity.com/trung.hoang&video
http://www.insperity.com/trung.hoangvideo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);