using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"abc\/\K([\w\.]+)(\&\w+)$";
string input = @"http://www.insperity.com/abc/trung.hoang&video
http://www.insperity.com/abc/trung.hoang&video&fsdf
http://www.insperity.com/abc/trung.hoangvideo
http://www.insperity.com/trung.hoang&video
http://www.insperity.com/trung.hoangvideo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}