import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "abc\\/\\K([\\w\\.]+)(\\&\\w+)$";
final String string = "http://www.insperity.com/abc/trung.hoang&video\n"
+ "http://www.insperity.com/abc/trung.hoang&video&fsdf\n"
+ "http://www.insperity.com/abc/trung.hoangvideo\n"
+ "http://www.insperity.com/trung.hoang&video\n"
+ "http://www.insperity.com/trung.hoangvideo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}