$re = '/\[b\](?!\w*.\[\/b\])/m';
$str = 'By purely mathematical reasoning it is possible [b]to demonstrate ([i]or[/i] [b]prove) a theorem which...
[b]There is little point ([i]or[/i] [b]sense) in listing all of the known amino acids.
Much of the gravel is used [b]"as is" ([i]соl.[/i]) for building roads.
Tuberculin test [b]is of doubtful value in the elderly since its interpretation is very difficult.
[b](As) viewed from the top ([i]or[/i] [b]from above) the insect\'s abdomen swings to the top as if it were a rudder.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);