const regex = /\[b\](?!\w*.\[\/b\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[b\\](?!\\w*.\\[\\\/b\\])', 'gm')
const str = `By purely mathematical reasoning it is possible [b]to demonstrate ([i]or[/i] [b]prove) a theorem which...
[b]There is little point ([i]or[/i] [b]sense) in listing all of the known amino acids.
Much of the gravel is used [b]"as is" ([i]соl.[/i]) for building roads.
Tuberculin test [b]is of doubtful value in the elderly since its interpretation is very difficult.
[b](As) viewed from the top ([i]or[/i] [b]from above) the insect's abdomen swings to the top as if it were a rudder.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}