import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[b\\](?!\\w*.\\[\\/b\\])";
final String string = "By purely mathematical reasoning it is possible [b]to demonstrate ([i]or[/i] [b]prove) a theorem which...\n"
+ "[b]There is little point ([i]or[/i] [b]sense) in listing all of the known amino acids.\n"
+ "Much of the gravel is used [b]\"as is\" ([i]соl.[/i]) for building roads.\n"
+ "Tuberculin test [b]is of doubtful value in the elderly since its interpretation is very difficult.\n"
+ "[b](As) viewed from the top ([i]or[/i] [b]from above) the insect's abdomen swings to the top as if it were a rudder.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}