#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[b\](?!\w*.\[\/b\])"
Local $sString = "By purely mathematical reasoning it is possible [b]to demonstrate ([i]or[/i] [b]prove) a theorem which..." & @CRLF & _
"[b]There is little point ([i]or[/i] [b]sense) in listing all of the known amino acids." & @CRLF & _
"Much of the gravel is used [b]"as is" ([i]соl.[/i]) for building roads." & @CRLF & _
"Tuberculin test [b]is of doubtful value in the elderly since its interpretation is very difficult." & @CRLF & _
"[b](As) viewed from the top ([i]or[/i] [b]from above) the insect's abdomen swings to the top as if it were a rudder."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")