use strict;
my $str = 'Thor The Dark World 2013 Bluray 2160p x265 10Bit HDR TrueHD Atmos 7.1 mUHD -iCandy
something.without.8bit.whoknows
Something.just.with.h265.hvec in.it
Thor.The.Dark.World.2013.PROPER.1080p.UHD.BluRay.DD+7.1.x264-LoRD
Thor.The.Dark.World.2013.2160p.UHD.HDR10.BluRay.Multi.TrueHD.7.1.x265-4K4U
';
my $regex = qr/^(?!.*10[Bb]it)(.*[x|h]\.?(265|HEVC).*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}