import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*10[Bb]it)(.*[x|h]\\.?(265|HEVC).*)$";
final String string = "Thor The Dark World 2013 Bluray 2160p x265 10Bit HDR TrueHD Atmos 7.1 mUHD -iCandy\n"
+ "something.without.8bit.whoknows\n"
+ "Something.just.with.h265.hvec in.it\n"
+ "Thor.The.Dark.World.2013.PROPER.1080p.UHD.BluRay.DD+7.1.x264-LoRD\n"
+ "Thor.The.Dark.World.2013.2160p.UHD.HDR10.BluRay.Multi.TrueHD.7.1.x265-4K4U\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}