using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*10[Bb]it)(.*[x|h]\.?(265|HEVC).*)$";
string input = @"Thor The Dark World 2013 Bluray 2160p x265 10Bit HDR TrueHD Atmos 7.1 mUHD -iCandy
something.without.8bit.whoknows
Something.just.with.h265.hvec in.it
Thor.The.Dark.World.2013.PROPER.1080p.UHD.BluRay.DD+7.1.x264-LoRD
Thor.The.Dark.World.2013.2160p.UHD.HDR10.BluRay.Multi.TrueHD.7.1.x265-4K4U
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}