const regex = new RegExp('^(?!.*10[Bb]it)(.*[x|h]\\.?(265|HEVC).*)$', 'gm')
const str = `Thor The Dark World 2013 Bluray 2160p x265 10Bit HDR TrueHD Atmos 7.1 mUHD -iCandy
something.without.8bit.whoknows
Something.just.with.h265.hvec in.it
Thor.The.Dark.World.2013.PROPER.1080p.UHD.BluRay.DD+7.1.x264-LoRD
Thor.The.Dark.World.2013.2160p.UHD.HDR10.BluRay.Multi.TrueHD.7.1.x265-4K4U
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}