$re = '/([^\n])\n(?=[^\n])/m';
$str = 'A
B
b
C
D
E
F
G
H';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;