#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^\n])\n(?=[^\n])"
Local $sString = "A" & @CRLF & _
"B" & @CRLF & _
"b" & @CRLF & _
"C" & @CRLF & _
"" & @CRLF & _
"D" & @CRLF & _
"E" & @CRLF & _
"" & @CRLF & _
"F" & @CRLF & _
"G" & @CRLF & _
"H"
Local $sSubst = "$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)