import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\n])\\n(?=[^\\n])";
final String string = "A\n"
+ "B\n"
+ "b\n"
+ "C\n\n"
+ "D\n"
+ "E\n\n"
+ "F\n"
+ "G\n"
+ "H";
final String subst = "$1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}