use strict;
my $str = 'A
B
b
C
D
E
F
G
H';
my $regex = qr/([^\n])\n(?=[^\n])/mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";