# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([一-龟]+:)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\n"
test_str = (" 位: {\n"
" default: '左',\n"
" type: String,\n"
" },\n"
" 高: {\n"
" default: '',\n"
" type: [String, Number],\n"
" },\n"
" 宽: {\n"
" default: '',\n"
" type: [String, Number],\n"
" },\n"
" 驼高: {\n"
" default: '',\n"
" type: String,\n"
" },\n"
" 骆高: {\n"
" default: '',\n"
" type: String,\n"
" },\n"
" 样: {\n"
" default: '工 gong',\n"
" type: String,\n"
" },\n"
" 料: {\n"
" default: () => {\n"
" return []\n"
" },\n"
" type: Array,\n"
" },\n"
" 啥: {\n"
" defaule: () => {\n"
" return {}\n"
" },\n"
" type: Object,\n"
" },")
subst = "$1$2$3$4$5$6$7\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.