import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([一-龟]+:)\\s*([^\\n]*?)\\n\\s*([^\\n]*?)\\s*([^\\n]*?)\\n\\s*([^\\n]*?)\\s*([^\\n]*?)\\n\\s*([^\\n]*?)\\n";
final String string = " 位: {\n"
+ " default: '左',\n"
+ " type: String,\n"
+ " },\n"
+ " 高: {\n"
+ " default: '',\n"
+ " type: [String, Number],\n"
+ " },\n"
+ " 宽: {\n"
+ " default: '',\n"
+ " type: [String, Number],\n"
+ " },\n"
+ " 驼高: {\n"
+ " default: '',\n"
+ " type: String,\n"
+ " },\n"
+ " 骆高: {\n"
+ " default: '',\n"
+ " type: String,\n"
+ " },\n"
+ " 样: {\n"
+ " default: '工 gong',\n"
+ " type: String,\n"
+ " },\n"
+ " 料: {\n"
+ " default: () => {\n"
+ " return []\n"
+ " },\n"
+ " type: Array,\n"
+ " },\n"
+ " 啥: {\n"
+ " defaule: () => {\n"
+ " return {}\n"
+ " },\n"
+ " type: Object,\n"
+ " },";
final String subst = "$1$2$3$4$5$6$7\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}