const regex = /([一-龟]+:)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([一-龟]+:)\\s*([^\\n]*?)\\n\\s*([^\\n]*?)\\s*([^\\n]*?)\\n\\s*([^\\n]*?)\\s*([^\\n]*?)\\n\\s*([^\\n]*?)\\n', 'gm')
const str = ` 位: {
default: '左',
type: String,
},
高: {
default: '',
type: [String, Number],
},
宽: {
default: '',
type: [String, Number],
},
驼高: {
default: '',
type: String,
},
骆高: {
default: '',
type: String,
},
样: {
default: '工 gong',
type: String,
},
料: {
default: () => {
return []
},
type: Array,
},
啥: {
defaule: () => {
return {}
},
type: Object,
},`;
const subst = `$1$2$3$4$5$6$7\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);