package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([一-龟]+:)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\n`)
var str = ` 位: {
default: '左',
type: String,
},
高: {
default: '',
type: [String, Number],
},
宽: {
default: '',
type: [String, Number],
},
驼高: {
default: '',
type: String,
},
骆高: {
default: '',
type: String,
},
样: {
default: '工 gong',
type: String,
},
料: {
default: () => {
return []
},
type: Array,
},
啥: {
defaule: () => {
return {}
},
type: Object,
},`
var substitution = "$1$2$3$4$5$6$7\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}