$re = '/((?:ithelpdesk(?:|\d+)|deskserverithelp|itservicedeskhelp|ithelpservice(?:|\d+))@gmail.com)/im';
$str = 'ithelpdesk458@gmail.com
ithelpdesk@gmail.com
deskserverithelp@gmail.com
itservicedeskhelp@gmail.com
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;