use strict;
my $str = 'ithelpdesk458@gmail.com
ithelpdesk@gmail.com
deskserverithelp@gmail.com
itservicedeskhelp@gmail.com
';
my $regex = qr/((?:ithelpdesk(?:|\d+)|deskserverithelp|itservicedeskhelp|ithelpservice(?:|\d+))@gmail.com)/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";